Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install Red5 on cPanel/WHM (CentOS)
04-28-2010, 12:20 AM,
#11
RE: Install Red5 on cPanel/WHM (CentOS)
(04-27-2010, 01:41 PM)kiamaru Wrote:  yeeeeees. i have the ChatrouletteApp in my admin page. what i do next? i have a dedicace server

edit /jabbercam/config.php and point the rtmp to your server, as described in INSTALL.txt that's all.
Reply
05-05-2010, 12:37 PM,
#12
RE: Install Red5 on cPanel/WHM (CentOS)
N00b... where do I post to find someone to hire to configure and customize the clone I plan on purchasing?
Reply
05-19-2010, 08:21 AM,
#13
RE: Install Red5 on cPanel/WHM (CentOS)
init script for Red5 that will run on cPanel/WHM (CentOS) servers:
Quote: #!/bin/sh
# Startup script for Red5 flash streaming server on RedHat/CentOS (cPanel)
# chkconfig: 2345 95 55
# description: Red5 Flash Streaming Server
# processname: red5

PROG=red5
RED5_HOME=/usr/local/red5
DAEMON=$RED5_HOME/$PROG.sh
PIDFILE=/var/run/$PROG.pid

# Source function library
. /etc/rc.d/init.d/functions

[ -r /etc/sysconfig/red5 ] && . /etc/sysconfig/red5

RETVAL=0

case "$1" in
start)
echo -n $"Starting $PROG: "
cd $RED5_HOME
$DAEMON >/dev/null 2>/dev/null &
RETVAL=$?
if [ $RETVAL -eq 0 ]; then
echo $! > $PIDFILE
touch /var/lock/subsys/$PROG

fi
[ $RETVAL -eq 0 ] && success $"$PROG startup" || failure $"$PROG startup"
echo
;;
stop)
echo -n $"Shutting down $PROG: "
killproc -p $PIDFILE
RETVAL=$?
echo
[ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/$PROG
;;
restart)
$0 stop
$0 start
;;
status)
status $PROG -p $PIDFILE
RETVAL=$?
;;
*)
echo $"Usage: $0 {start|stop|restart|status}"
RETVAL=1
esac

exit $RETVAL
* this script will do the job better. I'll post another modified version later if we find any major issues
Reply
05-21-2010, 06:30 AM,
#14
RE: Install Red5 on cPanel/WHM (CentOS)
This may help somebody (most cPanel users) http://www.videosoftware.pro/forum/thread-65.html
Reply
05-23-2010, 02:25 PM,
#15
RE: Install Red5 on cPanel/WHM (CentOS)
This will help if Red5 admin is not found when accessing :5080/admin or :5080/admin/register.html

http://www.videosoftware.pro/forum/thread-71.html
Reply
05-27-2010, 11:08 PM,
#16
RE: Install Red5 on cPanel/WHM (CentOS)
the latest version is available for RED5 is 0.7 on site but download from google code using svn as the tarball of 0.7 on site is missing some of the files.

Export Variables for Ant & Java

export ANT_HOME=/usr/local/ant
export JAVA_HOME=/usr/lib/jvm/java
export PATH=$PATH:/usr/local/ant/bin
export CLASSPATH=.:$JAVA_HOME/lib/classes.zip
Reply
06-07-2010, 01:14 AM,
#17
Edit my.cnf (/etc/my.cnf) if your Red5 app is not connecting to MySQL
In some cases, doing all the above won't help you. The rtmp works, but "cannot connect to backend services".

Edit my.cnf found at /etc/my.cnf and remove the following line:

skip-networking

Quote:vi /etc/my.cnf
*press ESC and :wq to quit and save vi

Restart MySQL and give it a try.:
Quote:/etc/init.d/mysql restart
Reply
06-07-2010, 11:32 AM, (This post was last modified: 02-21-2011, 03:47 PM by RVC Video Chat.)
#18
RE: Install Red5 on cPanel/WHM (CentOS)
Here you find the latest description, all the above in one place: http://www.videosoftware.pro/forum/thread-91.html
Reply
02-11-2011, 07:13 PM,
#19
RE: Install Red5 on cPanel/WHM (CentOS)
when i am trying to start red5
getting this error



root@visichat [~]# /etc/init.d/red5 start
-bash: /etc/init.d/red5: /bin/sh^M: bad interpreter: No such file or directory
Reply
05-07-2011, 12:25 AM,
#20
RE: Install Red5 on cPanel/WHM (CentOS)
if you have problem install subversion in cpanel then use this technique

Code:
root@server [/usr/local/src]# yum install subversion
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.nluug.nl
* extras: ftp.nluug.nl
* updates: ftp.nluug.nl
Excluding Packages in global exclude list
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package subversion.i386 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Processing Dependency: neon >= 0.25.5-6.el5 for package: subversion
--> Processing Dependency: libneon.so.25 for package: subversion
--> Processing Dependency: libapr-1.so.0 for package: subversion
--> Processing Dependency: libaprutil-1.so.0 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: subversion
--> Processing Dependency: libapr-1.so.0()(64bit) for package: subversion
--> Running transaction check
---> Package apr.i386 0:1.2.7-11.el5_5.3 set to be updated
---> Package apr.x86_64 0:1.2.7-11.el5_5.3 set to be updated
---> Package apr-util.i386 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4 for package: apr-util
---> Package apr-util.x86_64 0:1.2.7-11.el5_5.2 set to be updated
--> Processing Dependency: libpq.so.4()(64bit) for package: apr-util
---> Package neon.i386 0:0.25.5-10.el5_4.1 set to be updated
---> Package neon.x86_64 0:0.25.5-10.el5_4.1 set to be updated
---> Package subversion.i386 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Running transaction check
---> Package postgresql-libs.i386 0:8.1.23-1.el5_6.1 set to be updated
---> Package postgresql-libs.x86_64 0:8.1.23-1.el5_6.1 set to be updated
---> Package subversion.i386 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
---> Package subversion.x86_64 0:1.6.11-7.el5_6.3 set to be updated
--> Processing Dependency: perl(URI) >= 1.17 for package: subversion
--> Finished Dependency Resolution
subversion-1.6.11-7.el5_6.3.x86_64 from updates has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.3.x86_64 (updates)
subversion-1.6.11-7.el5_6.3.i386 from updates has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.3.i386 (updates)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.3.i386 (updates)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.6.11-7.el5_6.3.x86_64 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

then You could temporarily remove perl from the /etc/yum.conf exclude line, install subversion, then add perl back to the /etc/yum.conf exclude line after you've gotten subversion installed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)